Light issues with my first Diana+ film

So after my last post about the Diana+, I’ve now had a further problem with the very first film that I took. I posted the film off to Peak Imaging to get processed but they gave me a call to say that there had been huge amounts of light leaked onto the film. They still processed the film to check, but as they suspected every shot was worthless.

It appears that you have to make sure that the film is kept as tight as possible on the spools to minimise the possibility of light leaking in.

I should have probably watched this video first showing the best method to load it.

Running the Diana+ is going to be expensive

I’ve now taken two rolls of film on my Diana+, and put the first one in to get processed this week. Now the Diana+ uses 120 medium format film, opposed to the more common 35mm. This has a number of implications. For starters it is harder to find the film, and not many places process it. Then, as per my recent tweet, it’s also going to be pricey. The film is not too expensive to buy, as you can see at amazon.co.uk, the cost is pretty competitive to 35mm. However, you get far fewer exposures on 120, either 12, or 16. So already the cost per shot is more. Then there’s processing. I recently got a standard 36 exposure 35mm film processed and put straight to CD for only £7. Compare that to the £19 I’ve just spent on getting 16 120 exposures processed, printed and put to CD, and you quickly realise that shooting with the Diana+ is going to be an expensive hobby, particularly when you consider the whole Lomography movement is about low-fi fun.

Update


Looks like the folks at Lomography might be aware that 120 is not that suitable for the Diana+ as I’ve just spotted that you can get aLomo Diana 35mm Back adapter that replaces the original back of the camera that then allows you to load and shoot standard 35mm film. Problem solved.